RE: Presenting dstillr: A Chrome Extension to Remove Spammy Wallet Messages
Cool project to filter the transfer page!
Your roadmap has good stuffs too.
A few remarks:
https://github.com/tdreid/dstillr/blob/master/src/dstillr.js#L34 and https://github.com/tdreid/dstillr/blob/master/src/dstillr.js#L37 => Any reasons for mixin function notation ?
https://github.com/tdreid/dstillr/blob/master/src/dstillr.js#L38 =>this is a little old school, how about a forEach that you use here https://github.com/tdreid/dstillr/blob/master/src/dstillr.js#L64
You could add prettier to your devDep, not everyone has it as a global package.
Good luck for the next features!
Your contribution has been evaluated according to Utopian policies and guidelines, as well as a predefined set of questions pertaining to the category.
To view those questions and the relevant answers related to your post, click here.
Need help? Write a ticket on https://support.utopian.io/.
Chat with us on Discord.
[utopian-moderator]
Hey @gregory.latinier
Here's a tip for your valuable feedback! @Utopian-io loves and incentivises informative comments.
Contributing on Utopian
Learn how to contribute on our website.
Want to chat? Join us on Discord https://discord.gg/h52nFrV.
Vote for Utopian Witness!
I appreciate the review and great feedback @gregory.latinier :)
That's a very good point about prettier.
I've opened Issue #18 to add the dependency.
Concerning the mismatched function notation. Early in the project I was having a go at avoiding ES6 on the theory that I could keep my code exceptionally small. That approach fell by the wayside. The line you pointed out was overlooked in switching gears.
I've opened Issue #17 to handle that soon.
Finally — yeah, the ol' school loop =) — by coincidence I had read recently that
for
is faster thanforEach
and the size of the set is potentially unlimited. So, I thought it might matter. But I'm not sure yet and I may indeed end up usingforEach
for readability.Thanks for the several valid points!